Skip to main content

Cloning Diary: adcfgclone.pl dbTier fails with "Control file creation failed"


Thursday morning and we have a cloning request, well Apps DBAs perform cloning periodically, and at times get adhoc requests from functional or development teams. This was an adhoc request and with below environment

1. Single node ebs 12.2.7
2. Oracle database 12.1.0.2
3. Non-RAC and Non-ASM

Issue we faced actually compelled me to understand cloning internals. It was a cold backup cloning.
We have a cold backup to test server and had to clone it onto another development server.


Just to summarize on where we actually faced this error, below is an account of what about steps we followed to achieve this -






We decided to go with dbTier because -
- Its a cold backup restore.
- dbTier will take care of database registration in inventory, relink and configuration of binaries, recreate controlfile, restore and configure database, start database and listener.


Lets head on towards the error -


Error
-----
 /     50% completed       RC-50004: Fatal: Error occurred in ApplyDatabase:
Control file creation failed
WARNING: RC-40201: Unable to connect to Database TEST1227.
StackTrace:
java.lang.Exception: Cannot connect to database using DBUtil
        at oracle.apps.ad.clone.ApplyDatabase.checkDBConnection(ApplyDatabase.java:3356)
        at oracle.apps.ad.clone.ApplyDatabase.doConf(ApplyDatabase.java:562)
        at oracle.apps.ad.clone.ApplyDatabase.doApply(ApplyDatabase.java:502)
        at oracle.apps.ad.clone.ApplyDatabase.<init>(ApplyDatabase.java:393)

        at oracle.apps.ad.clone.ApplyDBTier.<init>(ApplyDBTier.java:116)

ERROR at line 1:
ORA-01503: CREATE CONTROLFILE failed
ORA-01210: data file header is media corrupt
ORA-01110: data file : '/u01/oracle/db/apps_tech/data/system01.dbf'
ORA-01130: database file version 12.1.0.2.0 incompatible with ORACLE version
12.1.0.0.0
ORA-01110: data file 1: '/u01/oracle/db/apps_tech/data/system01.dbf'


Error clearly states we are struggling with compatible parameter. We checked parameter and spfile generation date.

adcfgclone.pl uses templates under ORACLE_HOME/appsutil/template to generate an spfile and this spfile is being used at startup.

compatible parameter being set here is 12.1.0.0.0 while parameter set in source database is 12.1.0.2.0.


Resolution -

RC-00118: Error occurred during creation of database; Control file creation failed (Doc ID 2446627.1)


1.Go in DB ORACLE_HOME/appsutil/template
2.Edit the afinit_db.ora by setting the compatible parameter to match your exact version as updated in the init parameters.
3.Rerun adcfgclone dbTier after removing files under oraInventory and stopping all the running processes on db user



Conclusion-

Though it will be interesting to know when Oracle will update afinit_db.ora file, traversing and exploring OH/appsutil/template is important and can be helpful in troubleshooting cloning issues.


Enjoy your weekend!!!







Comments

Popular posts from this blog

Logfile locations in EBS r12.1 and EBS r12.2

Startup/shutdown Apps tier services are started and stopped frequently and we must know logfiles when troubleshooting startup/shutdown issues. $INST_TOP/logs/appl/admin/log $INST_TOP/logs/appl/admin/log Apache OHS being part of opmn in r12.1 has continued in r12.2. Logfile locations for troubleshooting have been changed $INST_TOP/logs/ora/10.1.3/Apache/error_log[timestamp] $INST_TOP/logs/ora/10.1.3/opmn/HTTP_Server~1.log $IAS_ORACLE_HOME/instances/*/diagnostics/logs/OHS/*/*log*   OPMN Logfile locations for r12.1 and r12.2 have been changed $INST_TOP/logs/ora/10.1.3/opmn/opmn* $IAS_ORACLE_HOME/instances/*/diagnostics/logs/OPMN/opmn/* Oacore oacore in r12.1 is oc4j component and part of 10gAS. However, in r12.2, oacore is now a managed server for weblogic server $LOG_HOME/ora/10.1.3/j2ee/oacore/oacore*/ $LOG_HOME/ora/10.1.3/j2ee/oacore/oacore*/ $LOG_HOME/ora/10.1.3/opmn/oacore*/oacor...
Defragment workflow related tables in r12   References- 1.     How to Reorganize Workflow Tables? (Doc ID 388672.1) 2.     EBS Workflow (WF) Analyzer (Doc ID 1369938.1) Points to Remember –     Some workflow tables are associated to queues so that it is necessary to use the advance queuing instructions to reorganize them. For tables other than queue tables, please refer to different notes created by RDBMS team to reorganize tables. This activity depends on the RDBMS version.       Defragment tables in workflow r12 Verify tables are not associated to queues – SQL> select queue_table from dba_queue_tables   2   where queue_table like '%WF%'; QUEUE_TABLE ------------------------------ WF_CONTROL WF_DEFERRED WF_DEFERRED_TABLE_M WF_ERROR WF_IN WF_INBOUND_TABLE WF_JAVA_DEFERRED WF_JAVA_ERROR WF_JMS_IN WF_JMS_JMS_OUT WF_JMS_OUT WF_NOTIFICATION_IN WF...

Oracle EBS r12 migration to Solaris SPARC ** issues and solutions

Let me share a list of issues I faced when migrating a single node Oracle ebs r12.1.3 environment from Linux x86_64 to multinode Solaris SPARC machines. I have already shared ppt that was point of discussion before migration. Oracle ebs db platform migration Please note that below is set of issues and respective solutions while migration. I have not covered steps for migration in this post. I would also like to share list of references from metalink that were very handy during complete migration process. ·          Export/import process for 12.0 or 12.1 using 11gR1 or 11gR2 (Doc ID 741818.1) -           This document will be primarily used for database migration. ·          Application Tier Platform Migration with Oracle E-Business Suite Release 12 (Doc ID 438086.1) -           Apps tier will b...